I created a page by first inserting an image and aligning it left. I then preceded to add a paragraph of text containing four sentences with the drupal break preceding the first sentence. When inserting the break, FCKeditor forces a new paragraph.

Comments

Status:Active» Postponed (maintainer needs more info)

Could you post the code before the insertion, the code after the insertion and the code as you would have wanted it to be.

Priority:Normal» Critical
Status:Postponed (maintainer needs more info)» Active

Same problem here in Firefox 3.0.1.only (works as expected in IE6). For example...

1) Before inserting DrupalBreak:

<p>1st paragraph</p>
<p>2nd paragraph</p>

2) After inserting DrupalBreak between the 2 paragraphs:

<p>1st paragraph</p>
<!--break-->
<p>&nbsp;</p>
<p>2nd paragraph</p>

That's not a big problem by itself, but after saving the form and trying to edit the same content again, I invariably loose whatever came after the DrupalBreak. Instead the teaser appears twice. I can't figure what's going on here.

I confirm that empty paragraph is added, however I can't reproduce the second issue (after saving the form and trying to edit the same content again, I invariably loose whatever came after the DrupalBreak).

A couple of questions regarding the second problem:
- What are your FCKeditor profile settings (enabled by default, popup mode?)?
- Does it happen while editing a page or only when editing custom content?
- Does it happen in all browsers?
- Are you sure that you're using the latest 6.x-1.3-rc1? Did you clear browsers cache after upgrading?

Alternatively, could you send me a PM with a link and test account details where I could see it?

Assigned:Unassigned» my-family

I have the some problem (After saving the form and trying to edit the same content again, I invariably loose whatever came after the DrupalBreak. Instead the teaser appears twice).
- My profile settings is "enabled by default"
- It happens while editing various types of content
- It happens in Opera 9, Firefox 2, but NOT in IE7.
- I am using tne latest version of the FCK module (6.x-1.3-rc1)

Assigned:my-family» Unassigned
Priority:Critical» Normal

Do not assign yourself to a ticket unless you are working on fixing this issue and want to provide a patch, in such case please feel free to assign yourself again ;)

Another 'me, too' post - every time I hit the 'DrupalBreak' button, an extra <p>&nbsp;</p> is added on the next line after the break. I typically just hit the source and remove it out of habit... however, other site users without the 'Source' button in FCKEditor can't fix the drupal break bug, so I'd like to see it fixed. Not the biggest issue in the world for me, but glad it's not just me ;-)

Status:Active» Fixed

Fixed in CVS. Let me know if the nightly build that will be available tomorrow after midnight is working as expected.

Status:Closed (fixed)» Fixed

Will try it out - thanks!

[Edit: It's working great now! Don't have to switch over to code to fix it anymore. Thanks!]

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Status:Fixed» Closed (fixed)

Automatically closed - issue fixed for 2 weeks with no activity.