Hello, i use the latest drupal 6.x version.

So but now i have problems, with something really ... turns out not easy.

So i tried 2 image modules , and i tried manual with image tags. But nevertheless no images.
So maybe before i waste more time and fun with this, someone can point out to me what i missing?

I have permissions right i think, TINYMC installed (sys says OK, but want display either).

Here is an example, the 2nd blog post has an image assist tag and int image gets displayed in the backend, but not on the user view.
http://galaxymachine.de/

Cheers,
LM

Comments

Most likely you have not yet customized the HTML tags that are allowed by default, so the IMG tag is not allowed to display. Here's info that should help: Understanding Input Formats (why HTML you write is not appearing)

It's not complete, but this may help regarding understanding some of the many image options with Drupal: Roundup of image modules for Drupal

-- David
davidnewkerk.com | absolutecross.com
View my Drupal lessons & guides

Hi David,
i looked it up and first off to my logic, FULL HTML means this is already setup for FULL HTML.
So and i had trouble to follow your tips, as i cannot find anything where i can delete or allow certain tags. There is a filter ...

Well so but now what i overlooked first, there is NOW an option (from image assist) to enable inline images in post - from module image assist.

Why have so many clicks till i can enable a basic website feature?

Maybe ask this on install?

Thanks for your help, i was able to fix this now very fast,
thanksfull,
LM

Web-Design & Music
http://galaxymachine.de

And your concerns, regarding given full html to anonymous user ... well and does the img tag makes my site now vulnerable?

So why not have a setup with image (as i belive 90% of websites use), before peopel are forced to temper with all this .. and first of use time ...

Or have a page with current security information?

And i found now the editable tags in configure (FILTERED HTML).

LM

Web-Design & Music
http://galaxymachine.de

Good glad you were able to fix it. I'm not sure whether the IMG tag presents any security risks, though I assume that it might cause "some" minor risk, which is why it is off by default - I don't know for a fact though, and it may have no security risk (a quick google search did not immediately reveal anything about img tags being insecure). However I agree with you, that it should be enabled by default (if the security issues are non-existent or minor enough), as this is a very very common question, and as you said, people will enable it anyhow. I believe that since Drupal 7 when it is released will support image handling directly in core, it is likely that this will be solved at that point.

Also, yes it would be nice if Image Assist would enable its Input filter by default (I'm not sure if this is possible, but it would be helpful for new users if they don't read the installation instructions).

-- David
davidnewkerk.com | absolutecross.com
View my Drupal lessons & guides