I am unable to change the sending email address.

I have tried removing all the references to the default email in drupal and user settings, but it won't change the senders address. It comes up with a abc@mail.com on behalf of Default Email [xyz@mail.com].

I have been successful in removing the "on behalf of..." by setting the sender to xyz@mail.com. Now I want to change the sender to newsletter@mail.com without the "on behalf of..." showing up in the email. I am also using the send test feature, not actually sending the newsletter...

I started with rc2 yesterday, and saw there is a rc3 today, but it did not change anything.
using mime module, v6 drupal.

Please let me know if I am missing something? Thanks.

Comments

The 'on behalf of' is not simplenews related. I advise you to check your hosting panel or contact your host.

Yes, the "on behalf of" comes from my web host. My problem with simplenews/drupal is I cannot change the sending email from abc@mail.com to xyz@mail.com. I have changed the email address in the site information area, the mime mail settings, the user account email, and simplenews-newsletter, but it always sends the mail using abc@mail.com. is there another setting I am missing?

-------------------------------------------------------------

to answer my question, yes there is another setting... Under Content-Newsletters-Newsletter, choose the newsletter you want, and there is the email address to change! it is also at /content/simplenews/types

Sorry for the trouble. Great module. Thanks so much.

Try the edit link at admin/content/simplenews/types.

Status:Active» Closed (fixed)

No activity. Closing the issue.

Status:Closed (fixed)» Active

I configured "From Name" and "From Email Address" field at admin/content/simplenews/types however subscription emails uses simplenews defaults given at admin/settings/simplenews/newsletter.

I believe subscription emails should have "From Name" and "From Email Address" from admin/content/simplenews/types if configured.

Version:6.x-1.0-rc3» 6.x-1.0-rc6
Category:support» bug

I can confirm this too.

The From name and address uses the default settings found at admin/settings/simplenews/newsletter instead of the ones specified at admin/content/simplenews/types.

Smells like a bug to me.

Category:bug» support

vendeka, you are right in your assumption of how it should work. But I can not reproduce this error. Please describe all steps to reproduce this error.

Status:Active» Closed (fixed)

No activity for two weeks. Closing the issue.