Upon updating to latest imagefield/filefield module, the imagefield description field setting became disabled in the content type.

The scenario was:

* using imagefield/filefield with imagefield description showing
* updated modules to rc1 (I believe it happened with previous version as well)
* imagefield description was gone
* went to content type to enable

Thanks.

Files: 
CommentFileSizeAuthor
#4 filefield_description_update.patch1.14 KBquicksketch

Comments

Thanks for the report. Which version were you upgrading from?

I tend to do updates every couple weeks. The tar files I have used (in reverse order) are: rc1, beta3, alpha7, alpha6, alpha5. Unfortunately, I'm not sure if it happened between alpha7 and beta3 or between beta3 and rc1, since I did those updates pretty recently. I think it was probably from alpha7 and beta3.

I think it was probably from alpha7 and beta3.

Thanks, this seems most likely, since there were several database updates between those two versions. Sorry for the inconvenience, I'll try to reproduce and get it fixed.

Status:Active» Fixed
StatusFileSize
new1.14 KB

I couldn't find any direct problems with the upgrade path, but with a lot of people manually rerunning updates, this could be a problem if the update is run more than once. This patch makes it so that rerunning the update multiple times doesn't have the detrimental effect of losing the "description" field value. This should also prevent a problem if ImageField is updated first, then the FileField update follows.

Awesome! That very well could've been the problem of running update.php multiple times. Thanks for the super fast turn around time!

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.