In the page of report of my site, the upload progress module gives me an error. The error is the following:

"Upload progress Not trained
Your server is capable of displaying file upload progress, but does not have the required libraries. It is recommended to install the PECL uploadprogress library (prefered) or to install APC."

I have tried to install the PECL uploadprogress library, but I have not succeeded there. There is someone who is able to point out whether to find the instructions for a correct installation of such bookstores. On my server Ubuntu 8.10 turns.

Comments

subscribing

hostmonster - Apache

D

I don't think that the PECL module can be installed if your host is using php/fast-cgi
See http://drupal.org/node/464412
and
http://drupal.org/node/441046
Regards,
Brian Brown, Ph.D.

Brian Brown, Ph.D.

I use Hostmonster, too, and just emailed their support asking about it. Their response:

I apologize for the problem. Looking into this extension further, we've found that this is something that only works through mod_php, something we don't currently use. We've opted to run php through cgi instead. This isn't a PECL package that will work with our current setup, however if there are any other modules we can install for you, please be sure to let us know, and as long as it's a stable release, and we meet all prerequisites, we should be able to take care of that for you.

Personal: justinstanley.net
Nerdly: nerdliness.com

they told me the same straight over the phone... sounds strange though why can't they just add it.

D

Hi to all
Now any one can say me how we can install this lib?

zakir.gori

Hoi zakir.gori,

Maybe you should look here:
http://freestylesystems.co.uk/blog/installng-pecl-uploadprogress-extensi...

JanWalhof

My question is: Can we work with Drupal without these libraries? To what extent influences to work with Drupal?

all this does is provide some visual feedback while uploads occur. Its not necessary.

and for some people "some visual feedback" is really important

D