getting this messaqge for every thumbnail on every page on my site (www.mudlark.com.au), this basically disables the use of the front page. all images are being displayed as full images instead of thumbnails.

this error message is appearing on every page with an image.
warning: is_file(): Stat failed for files/images/100_0831.jpg (errno=13 - Permission denied) in /home/mudla107/public_html/mudcms/includes/image.inc on line 83.

I was getting an error message "table .fscache not found," I don't know why, because it was working fine for months, then the fscache table seems to have disappeared. I re-added it, but it doesn't seem to have fixed the problem.

this is serious, I had this problem before, and I couldn't fix it. luckily it was while the site was in testing, so I just re-installed drupal, but now it's full of content and that can't be done.

please, let me know if this is a bug in images, or how I can fix it.

ned

Comments

I also get these errors when I try to edit an image;

* The directory files/images is not writable.
* The directory files/images/temp does not exist.

and it seems to be true, the permissions for the images folder are set to 744, and I can't change them. I think they need to be 733 right? what's the go with this folder, why can't I change it?

ned

I'm getting the same problem with the same message. All my images start out correct, then the thumbnail expands to the whole screen and overlaps each other. I've removed Image module and re-installed it, but that has not corrected the problem......any help would be greatly appreciated
Jeremy

Category:bug» support

If you have shell access you need to probably chmod 777 files/images. If not, your going to have to figure out how to do this through your hosts interface(CPanel or what not). This is required so that the image manipulation can modify and create images in the directory as the 'nobody' I'm going to get your webserver is running as.

I've been having the exact same problem with missing thumbnails and stat errors with my site in the last few weeks, with the added problem that I can't even access the directory where the the images are stored (files/images/). I get a "550 Can't change directory to /public_html/files/images/: Permission denied error". I contacted my hosting tech support and they can't access the directory either.

Due to this added complication, there's no way for me to impliment neclimdul's proposed chmod change to 777. Furthermore, I know the thumbnails were working earlier, so it doesn't make sense to me that permissions would have spontaneously changed on that directory. Could there be a more systematic problem here?

My (broken) gallery is here: http://www.speak.org.uk/image

Status:Active» Closed (fixed)

Closed due to inactivity..