Have installed this and the bing meta tag is correctly generated. Bing kept reporting failures so I copied the generated code into the top of my HEAD section in my template (page.tpl.php). Authentication was fine.

I presume this is because I am using YUI menus which put a lot of javascript into the head. The meta tags are generated below this and my guess is that Bing only searches the first X lines or words within the tag.

Please can the header meta tags be moved to the top. You can see what I mean by looking at the generated code of www.sean-gates.com. The first tag is the one that I have inserted manually because the second one kept failing

Comments

That could depend from the used theme, because with Garland I get the meta tags printed before any included JavaScript files.

  <head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="alternate" type="application/rss+xml" title="Drupal RSS" href="http://sunradio.local/dr61/rss.xml" />
<link rel="shortcut icon" href="/dr61/misc/favicon.ico" type="image/x-icon" />
<link rel="canonical" href="http://sunradio.local/dr61/" />
<meta name="keywords" content="default, no-custom-page" />
<meta name="description" content="description: none" />
<meta name="abstract" content="abstract: default" />
<meta name="revisit-after" content="10 days" />
    <title>Drupal</title>
    <link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/book/book.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/node/node.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/poll/poll.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/system/defaults.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/system/system.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/system/system-menus.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/modules/user/user.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/sites/all/modules/views/css/views.css?Z" />
<link type="text/css" rel="stylesheet" media="all" href="/dr61/themes/garland/style.css?Z" />
<link type="text/css" rel="stylesheet" media="print" href="/dr61/themes/garland/print.css?Z" />
    <script type="text/javascript" src="/dr61/misc/jquery.js?Z"></script>
<script type="text/javascript" src="/dr61/misc/drupal.js?Z"></script>
<script type="text/javascript" src="/dr61/sites/all/modules/poormanscron/poormanscron.js?Z"></script>
<script type="text/javascript">

It is caused from YUI module, which adds the lines to include JavaScript files using drupal_set_html_head().

Status:Active» Fixed

I changed the code, which should now put its output right after the line setting the output content type. As Nodewords uses hook_preprocess_page(), no other module should be able to put its output before Nodewords.

Cool - thanks

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.