Right as we run for the D7 alpha we have #653580: Upgrade to jQuery 1.4 and jQuery UI 1.8 alphas. We should release with the latest jQuery UI if at all possible.

Files: 
CommentFileSizeAuthor
#88 Home text isn't disable.png139.34 KBaspilicious
#86 jquery-ui-1-8_679036_86.patch266.61 KBRobLoach
PASSED: [[SimpleTest]]: [MySQL] 18,734 pass(es).
[ View ]
#79 jqueryui18.patch266.1 KBRobLoach
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jqueryui18.patch.
[ View ]
#77 jquery-ui-1-8_679036_77.patch266.06 KBmfer
PASSED: [[SimpleTest]]: [MySQL] 18,748 pass(es).
[ View ]
#77 ui-anim_basic_16x16.gif1.52 KBmfer
#77 delete_cvs_commands.txt1.32 KBmfer
#75 jquery-ui-1-8_679036_75.patch491.29 KBmfer
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_75.patch.
[ View ]
#72 jquery-ui-1-8_679036_71.patch491.97 KBmfer
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_71.patch.
[ View ]
#69 jquery-ui-1-8_679036_69.patch493.54 KBmfer
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_69.patch.
[ View ]
#66 jquery-ui-1-8_679036_66.patch493.17 KBmfer
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in jquery-ui-1-8_679036_66.patch.
[ View ]
#66 ui-anim_basic_16x16.gif1.52 KBmfer
#64 jqueryui18rc3.patch729.06 KBcasey
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jqueryui18rc3.patch.
[ View ]
#59 679036_jquery-ui-1.8rc3.patch626.73 KBneclimdul
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 679036_jquery-ui-1.8rc3.patch.
[ View ]
#51 679036.patch500.06 KBRobLoach
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 679036.patch.
[ View ]
#44 upgrade-jquery-ui-to-1.8rc2-v1.patch496.54 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in upgrade-jquery-ui-to-1.8rc2-v1.patch.
[ View ]
#34 jquery-ui-1.8rc1.patch511.04 KBcasey
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1.8rc1_0.patch.
[ View ]
#32 jquery-ui-1.8rc1.patch479.68 KBcasey
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1.8rc1.patch.
[ View ]
#29 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch480.89 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch.
[ View ]
#25 0001-upgrade-to-jQuery-UI-1.8rc1-v3.patch480.8 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v3.patch.
[ View ]
#19 0001-upgrade-to-jQuery-UI-1.8rc1-v2.patch464.27 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v2.patch.
[ View ]
#11 upgrade-to-jQuery-UI-1.8b1.patch438.75 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8b1.patch.
[ View ]
#5 0001-update-to-jQuery-UI-1.8a2.patch587.13 KBmarvil07
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-update-to-jQuery-UI-1.8a2.patch.
[ View ]

Comments

Title:Upgrade to jQuery 1.8Upgrade to jQuery UI 1.8

Mark #680208: Upgrade jQuery UI to 1.8 as a duplicate of this issue.

Adding to the alpha hit list. I don't think this'll make it in by then, but if it could have a patch ready to go with the current beta code that's been tested w/ jQuery 1.4, that'll help tremendously with getting it in as soon as possible.

This would be a tremendous boon to we who tinker with JavaScript. The jQuery documentation has historically been rather poor for the previous version, though I suspect that will have improved with their new API site.

Status:Active» Needs work
StatusFileSize
new587.13 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-update-to-jQuery-UI-1.8a2.patch.
[ View ]

Here is a starting patch, it rename the alpha zip files to the drupal ones, using the minified version, except for jquery.cookie.js because the zip file contains only the expanded version.

warning: overlay stop working after updating ui lib, and I'm not sure how to test this(I do not update jQuery lib since this jQuery UI 1.8a2 have the jquery-1.3.2.js on its zip)

About testing js: JavaScript Tests at Testing and Quality Assurance group in g.d.o

Sub.

FYI jquery ui 1.8b1 is out. Adds autocomplete awesomeness.

http://jqueryui.com/docs/Changelog/1.8b1

Assigned:Unassigned» marvil07

Also richard worth tweeted 1 week until 1.8 Seems a little quick for me for expecting 1 more beta and an rc, but thought I'd pass it along since it seems it will be released well before D7.

Assigned:marvil07» Unassigned
StatusFileSize
new438.75 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8b1.patch.
[ View ]

here a new patch that includes jQuery UI 1.8b1

Why is a compressed version of jquery.cookie.js being removed and replaced with an uncompressed version?

Read #5. it's because the current zipped files contain the uncompressed version. I'm sure when 1.8 is released then the compressed one will come in the zip.

Maybe a better question is what's the difference between jquery.cookie.js that we currently have and the version bundled with jquery ui 1.8b1

Not sure what exact version drupal now have in core, but the version on the jquery ui zip is:
jquery-ui-1.8b1/external/jquery.cookie-r6165.js

So, it should be r6165 on the original repo.

subscribing

wrong post

RC1 was released http://jquery14.com/day-14 \o/

StatusFileSize
new464.27 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v2.patch.
[ View ]

here a new patch that includes jQuery UI 1.8rc1

jQuery UI now ships jQuery 1.4.1, so we now depend on #653580: Upgrade to jQuery 1.4

This change is not just a simple case of updating files. jQuery UI 1.8 comes with some new stuff that needs to be defined in system_library() and the widget stuff from ui.core.js was broken out into ui.widget.js. This needs to be included in the dependancy chain for the widgets and effects to work.

Also, jquery ui changed the name of the files. They are all not prefixed with "jquery.". We should probably update to the new file names.

Oh sweet merciful crap. :\

Once this gets RTBC-ish, if someone could do me a HUGE favour and figure out the proper cvs add/remove commands I would love you forever (or if someone has a nice trick to deal with this mass rename issue I'm all ears).

Patch of #19 does not apply to HEAD.

@webchick - I'll try to make sure it just works for you :)

Assigned:Unassigned» marvil07

Assigned:marvil07» Unassigned
Status:Needs work» Needs review
StatusFileSize
new480.8 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v3.patch.
[ View ]

@mfer: yep, that's the reason why I'm not changing the status to "needs review", but now I can :-)

@webchick: cvs add misc/ui/effects.fade.js misc/ui/ui.autocomplete.css misc/ui/ui.autocomplete.js misc/ui/ui.button.css misc/ui/ui.button.js misc/ui/ui.mouse.js misc/ui/ui.position.js misc/ui/ui.widget.js (they are only the newones)

@casey: thanks for trying the patch :-), something strange here between vcs(re-rolling from cvs instead of dvcs :-p) .. so finally.. after some time dealing with cvs and actually reading how to add files in a patch for CVS(hint: cvsdo add).

Ok so, making a summary until how, here is the new patch, that:

- replace jQuery UI 1.8rc1
- add Id keywords on file headers.
- make the patch apply
- ui.stackfix(added in 1.8a1 or 1,8a2 IIRC) was removed in jQuery UI 1.8rc1, so remove it
- reflect new dependency chain in jQuery UI files

And now: overlay works again ;-)

Status:Needs review» Needs work

The last submitted patch, 0001-upgrade-to-jQuery-UI-1.8rc1-v3.patch, failed testing.

I am really sorry but it still doesn't apply correctly :)

Your patch is removing all code from various ui files.

Looking at your patch I see multiple "\ No newline at end of file". These seem to prevent me from applying your patch. I believe its a Drupal standard to add a newline at end of every file.

Also, did you use the right commands? http://drupal.org/patch/create

Status:Needs work» Needs review
StatusFileSize
new480.89 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch.
[ View ]

great hint casey.

yep actually the original jQuery UI used have files with different end of lines(unix/dos) and also files with no end new line of file, so that make it tricky.

I tried to avoid those problems by including it when necessary.

And now I try to apply the patch on a clean cvs checkout, so this time it should work :-)

Status:Needs review» Needs work

The last submitted patch, 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch, failed testing.

Not sure what's the problem here.
I used the way proposed on http://drupal.org/patch/create

Literally I did:

$ # changes
$ cvsdo add misc/ui/effects.fade.js misc/ui/ui.autocomplete.css misc/ui/ui.autocomplete.js misc/ui/ui.button.css misc/ui/ui.button.js misc/ui/ui.mouse.js misc/ui/ui.position.js misc/ui/ui.widget.js
$ cvs diff -upN > 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch

I tried to apply it on a clean checkout with success, like I mention:

$ patch -p0 < 0001-upgrade-to-jQuery-UI-1.8rc1-v4.patch

Any ideas?

Status:Needs work» Needs review
StatusFileSize
new479.68 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1.8rc1.patch.
[ View ]

Not really, but this should work :)

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1.8rc1.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new511.04 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1.8rc1_0.patch.
[ View ]

No it didn't

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1.8rc1.patch, failed testing.

Issue tags:+jQuery

subscribe

subscribe

sub

subscribe

Status:Needs work» Needs review

jQuery 1.4.2 Released jQuery 1.4.2 Min
jQuery UI 1.8RC2 Released jQuery UI 1.8RC2

Can a patch create a file if it doesn't exist? I think I read somewhere it can't, but I might be completely wrong.

The patch from #29 is trying to create these files:

misc/ui/effects.fade.js
misc/ui/ui.autocomplete.css
misc/ui/ui.autocomplete.js
misc/ui/ui.button.css
misc/ui/ui.button.js
misc/ui/ui.mouse.js
misc/ui/ui.position.js
misc/ui/ui.widget.js

with strings like these:

--- /dev/null 1 Jan 1970 00:00:00 -0000
+++ misc/ui/effects.fade.js 29 Jan 2010 22:40:00 -0000

I think that might be the problem.
From the handbook page:

Adding/Deleting Files Using the Diff Command

Note: the fakeadd utility can save you from fiddling with CVS internals.

Having one patch represent all code changes, including adding and deleting files is vital. The problem is that "cvs diff" won't let you diff files that haven't been added (cvs add) or deleted (cvs rm) from the repository. To do that you would normally need to get read/write permissions for the repository. Unless you are the maintainer of the module you won't have that, but there are a few solutions.

note: You use the -N switch to account for new or deleted files.

cvsdo
For linux users, a script called cvsdo is available to use that will basically do the long steps below for you:
cvsdo add file.module
it is part of the overall useful cvsutils package. for Ubuntu/Debian users:
sudo apt-get install cvsutils
Fedora users:
sudo yum install cvsutils

fakeadd
a shell script that again, does the work below for you.
http://tinyurl.com/fakeadd

by-hand method
see below about changing CVS/Entries to add and remove files manually.

Once you've added/removed the file from CVS by one of these methods, you can now use:
cvs diff -upN directory > filename.patch
or
diff -upN original_directory new_directory > filename.patch

Does this help?

@Jolidog it can. when the final jquery UI 1.8 comes out i was planning on rolling a patch that just works.

StatusFileSize
new496.54 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in upgrade-jquery-ui-to-1.8rc2-v1.patch.
[ View ]

Here a new version of the patch with 1.8rc2.

About the non-applying patch.. well I'm following the next steps(form http://drupal.org/patch/create):
- change files
- add new files

cvsdo add misc/ui/effects.fade.js misc/ui/ui.autocomplete.css misc/ui/ui.autocomplete.js misc/ui/ui.button.css misc/ui/ui.button.js misc/ui/ui.mouse.js misc/ui/ui.position.js misc/ui/ui.widget.js misc/ui/images/ui-anim_basic_16x16.gif

- roll the patch
cvs diff -upN > upgrade-jquery-ui-to-1.8rc2-v1.patch

@mfer: It seems like you know how to do it in the right way(tm) :-), maybe you can suggest me how different your method is from the one I follow. I suppose 1.8 release is gonna be shipped with the right EOLs, so maybe that could make my problem disappear.

Like I said, I tried this patch in a new cvs checkout, and it applies clean, please try it :-)

About overlay module: It still works, but there is a bug on #overlay-container height(it only take your screen size, not all page in overlay size)
About dependency: 1.8rc2 play well with 1.4.2, so AFAIK we need patch from #653580: Upgrade to jQuery 1.4, comment #90
About what is missing: Wait for jquery-ui 1.8 official relelase, with should include minified version of jquery.cookie.js
About why I re-rolling against 1.8rc2 instead of waiting for official 1.8: help testing drupal side js compatibility with a little more time.

So, hoping bot like this.. :-p

Status:Needs review» Needs work

The last submitted patch, upgrade-jquery-ui-to-1.8rc2-v1.patch, failed testing.

About overlay module: It still works, but there is a bug on #overlay-container height(it only take your screen size, not all page in overlay size)

Rob Loach make that problem disappear :-) #653580: Upgrade to jQuery 1.4 (comment #91)

So, with the Overlay fixes in the jQuery 1.4 issue, is it possible to commit that patch and use it with jQuery UI 1.7.2 until 1.8 "proper" is out, or are they still co-dependent?

I think with this patch, we should switch to jQuery UI 1.8's new naming convention with the filenames. jquery.ui.dialog.js as opposed to just ui.dialog.js.

@webchick

So, with the Overlay fixes in the jQuery 1.4 issue, is it possible to commit that patch and use it with jQuery UI 1.7.2 until 1.8 "proper" is out, or are they still co-dependent?

jQuery UI 1.7 is compatible with jQuery 1.4, which means we could commit the jQuery 1.4 patch and wait off on this issue until the final jQuery UI 1.8 is released.

@marvil07

Rob Loach make that problem disappear :-)

I can't take credit for that one. Casey's doing!

#653580: Upgrade to jQuery 1.4 is commited :-)

I think with this patch, we should switch to jQuery UI 1.8's new naming convention with the filenames. jquery.ui.dialog.js as opposed to just ui.dialog.js.

Yep, that took me unnecessary time in renaming before I made the patches. I was really not sure if jquery ui was changing naming convention or if that was a "dev" naming convention :-p

So, totally agree in changing names to the new convention if it is :-)

BTW: can someone help me to understand why bot do not like the way I'm following(see my comments in this issue) to make patches? (note the patch applies manually)

Detect invalid patch format
Ensure the patch only contains unix-style line endings.

You have to select unix style endigs...
If you're using eclipse you can configure that somewhere...

Status:Needs work» Needs review
StatusFileSize
new500.06 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 679036.patch.
[ View ]

This patch names all the files the standard jQuery UI 1.8 naming and updates to jQuery UI 1.8rc3. The Overlay is working just fine from my testing.

Status:Needs review» Needs work
Issue tags:-jQuery, -webchick's D7 alpha hit list

The last submitted patch, 679036.patch, failed testing.

Status:Needs work» Needs review

#51: 679036.patch queued for re-testing.

Status:Needs review» Needs work
Issue tags:+jQuery, +webchick's D7 alpha hit list

The last submitted patch, 679036.patch, failed testing.

@rgregory this patch contins windows endings, so it never will pass testbot

That's strange, because I made it on Linux.

FYI, I've been just holding off on this until 1.8 is actually released.

We still need to test in advance of 1.8's official release so we can get this in quickly after, so interim patches are highly appreciated.

And apparently http://dev.jqueryui.com/query?status=accepted&status=assigned&status=new... is a list of their remaining criticals and blockers, but it's having a little trouble displaying atm.

Status:Needs work» Needs review
StatusFileSize
new626.73 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in 679036_jquery-ui-1.8rc3.patch.
[ View ]

Very odd. I was rolling my own version of the patch, built in linux too so lets see if it works any better. I went ahead and ran dos2unix on everything including the ui files just to make sure...

Status:Needs review» Needs work

The last submitted patch, 679036_jquery-ui-1.8rc3.patch, failed testing.

Maybe there is still an UI file with windows endings...
Strange...

This lines contain strange caracters.

-    // The link 'description' — either derived from the hook_menu 'description' or
-    // entered by the user via menu module — is saved as the title attribute.
+    // The link 'description' ��� either derived from the hook_menu 'description' or
+    // entered by the user via menu module ��� is saved as the title attribute.

Sorry, I think that is eclipse being lame. I'll take another look at it in a reasonable edit and see if I can sort that part out.

Is there some way to check if the test bot is giving us a false positive here? As I noted, I ran dos2unix on all the files so I can't see why it would be failing.

Status:Needs work» Needs review
StatusFileSize
new729.06 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jqueryui18rc3.patch.
[ View ]

Another try

Status:Needs review» Needs work

The last submitted patch, jqueryui18rc3.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new1.52 KB
new493.17 KB
FAILED: [[SimpleTest]]: [MySQL] Invalid patch format in jquery-ui-1-8_679036_66.patch.
[ View ]

Even though the formal announcement for jQuery UI 1.8 release has not gone out yet the tag has been created and the file download is in place. I'd expect the announcement soon. You can see them at http://code.google.com/p/jquery-ui/source/checkout and http://code.google.com/p/jquery-ui/downloads/list.

So, here is a patch and the one additional image that needs to be placed in /misc/ui/images

@webchick, I applied the patch against CVS head and it removed the old files (with the old naming convention) and added the new files with the new names.

I did some basic testing and it looked to work. I needs more testing, though.

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1-8_679036_66.patch, failed testing.

Every one of the patches for this has failed. I wonder if there something with the jQuery UI files that is causing this problem. Or, is there something specific with the testing system I don't know about when adding/removing files?

Status:Needs work» Needs review
StatusFileSize
new493.54 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_69.patch.
[ View ]

There was a reference in the diff for the binary file from #66. Removed that. That file is still needed but it may not have liked it in the patch file.

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1-8_679036_69.patch, failed testing.

Just needs a reroll :)

Status:Needs work» Needs review
StatusFileSize
new491.97 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_71.patch.
[ View ]

Lets try this one more time. It seems there were extra carriage returns in the jQuery UI files causing some havoc. This requires the image from #66 as well.

"-webkit-border-top-left-radius: 4px/*{cornerRadius}*/; border-top-left-radius: 4px/*{cornerRadius}*/; "

This nice patch will make opera 10.50 and IE9 support rounded corners completly :)

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1-8_679036_71.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new491.29 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jquery-ui-1-8_679036_75.patch.
[ View ]

Here is a new patch with some missing content. oops. This is what I get for trying a new workflow on this patch.

Status:Needs review» Needs work

The last submitted patch, jquery-ui-1-8_679036_75.patch, failed testing.

Status:Needs work» Needs review
StatusFileSize
new1.32 KB
new1.52 KB
new266.06 KB
PASSED: [[SimpleTest]]: [MySQL] 18,748 pass(es).
[ View ]

This patch should work. Or, at least apply. There are 3 files here:

  • The patch file that makes the changes to core and adds the jquery ui files.
  • The image that needs to be added to /misc/ui/images
  • The CVS commands to remove the old files all in one line. Run it from the root of drupal.

The 3rd file is included per webchicks request (see above). Some systems, like git, can remove files in a diff. CVS/patch cannot. So, here are the commands.

So far, Testing in Chrome and Firefox 3.5 have shown no errors as the result of the patch in #77

StatusFileSize
new266.1 KB
FAILED: [[SimpleTest]]: [MySQL] Unable to apply patch jqueryui18.patch.
[ View ]

I was getting some jirkiness with the Overlay without jQuery UI: Position alongside the Dialog. Also fixed a typo "Positionr'.

Status:Needs review» Needs work

The last submitted patch, jqueryui18.patch, failed testing.

#77

Overlay not wroking
I think install animation (progressbar) not working

@aspilicious can you provide more detail. Like the Browser, version, and operating system you are having trouble on.

I'll test again with a fresh install!
I'll provide details later.

Ok I was wrong #77 was working, just needed an new database and a fresh install.
What's the difference between #77 and #79??

There are three things different between #79 and #77....

  1. Fixes a typo: "Positionr"
  2. Adds "ui.position" to the dialog. Without it, the locational positioning of the Overlay was kind of jirky for me. When the Overlay would pop up, the scrollbar would move down. Adding the Position plugin fixed that.
  3. Seems another difference is that the bot doesn't like the patch. Not entirely sure why...

Status:Reviewed & tested by the community» Needs review
StatusFileSize
new266.61 KB
PASSED: [[SimpleTest]]: [MySQL] 18,734 pass(es).
[ View ]

It will probably hate this one too. It moves the dependency on "ui.position" over to overlay_library() rather than on "ui.dialog" itself.

Note the instructions mfer posted at #77.

Status:Needs work» Reviewed & tested by the community

Great! Patch doesn't seem to bring any huge problems along.

Status:Needs review» Reviewed & tested by the community
StatusFileSize
new139.34 KB

this related?

NOP it isn't related!
Ignore screenshot!

Status:Reviewed & tested by the community» Fixed

Ok, committed this to HEAD. Thanks for all of the epic efforts getting a patch to work with testing bot, and thanks to mfer for the list of rm commands to run.

It would be lovely for someone to double-check and make sure this made the transition okay; CVS is a complete pain in the ass. :P~

Version:7.x-dev» 6.x-dev
Status:Fixed» Needs work

Hi, installed jQuery UI 1.8 + same for the themes 1.8 in the jQuery UI themes dir on Drupal 6. Then the "jQuery UI update" module and copying files to /misc dir.

Ofcourse it was not working, so I found this patch. But:
* It seems to be for Drupal 7 only, so Drupal 6 patch is still missing?
* I don't understand exactly what (part of) which different files I have to change and exactly where in my Drupal install;
* I'm not sure if I first have to install the jQuery UI (&themes) version 1.7 before installing 1.8?

Anyway, I suppose that -untill these questions have been answered and a patch for Drupal 6 exists- I have to install jQuery UI version 1.7 to get it working on my Drupal? Right now the module is there, but I'm unable to vink it on; it's blocked saying that it depends on jQuery UI what 'seems' to be missing.

Version:6.x-dev» 7.x-dev
Status:Needs work» Fixed

Drupal 6 is API frozen, so will never be including jQuery UI. Restoring issue properties.

People who want to use jQuery UI on Drupal 6 will need to use the jQuery Update and jQuery UI modules. Not sure the answers to your questions, but they'd be for those queues, not the core queue.

Status:Fixed» Closed (fixed)
Issue tags:-jQuery, -webchick's D7 alpha hit list

Automatically closed -- issue fixed for 2 weeks with no activity.