When I try to import my blog XML, generated from wordpress.com I get this error:

    * warning: XMLReader::read() [xmlreader.read]: /home/xxx/xxx.co.uk/sites/default/files/wordpress/wordpress.2010-03-11.xml:1082: namespace error : Namespace prefix atom on link is not defined in /home/xxx/xxx.co.uk/sites/all/modules/wordpress_import/wordpress_import.module on line 1425.
    * warning: XMLReader::read() [xmlreader.read]: ription+xml" href="http://xxx.wordpress.com/osd.xml" title="the commune" in /home/xxx/xxx.co.uk/sites/all/modules/wordpress_import/wordpress_import.module on line 1425.
    * warning: XMLReader::read() [xmlreader.read]: ^ in /home/xxx/xxx.co.uk/sites/all/modules/wordpress_import/wordpress_import.module on line 1425.
    * warning: XMLReader::read() [xmlreader.read]: An Error Occured while reading in /home/xxx/xxx.co.uk/sites/all/modules/wordpress_import/wordpress_import.module on line 1425.
    * This file does not appear to be a valid WXR file. The file is either corrupted or invalid XML. In some versions of WordPress, the export function can produce malformed XML. Please see README.txt (included in the module archive) for further guidance.

I tried with both the developer version and the stable 2.x. Any solutions? I would attach my XML but it's 14meg.

Comments

Assigned:Unassigned» lavamind

The README in the development version has additional detailed guidelines for dealing with XML problems. In this specific case, it seems like one of your Wordpress plugins is causing extra XML to be included in your export file. Please try disabling any Wordpress plugin related to feeds and creating a new export file.

The module interface states that it will not work with XML larger than 8MB.

I am also experiencing this error with an XML file that is only 600KB.

I was having trouble with this today. I opened my XML file and deleted the atom.link tag:

That did the trick for me. Thanks for pointing me to the dev README.

THANK YOU!

Removing the two atom:link tags proved to be the solution for me as well.

Status:Active» Fixed

I did a search for "atom:link" and "atom.link" doesn't exist in my file but I'm getting the same type error. Below is what I'm receiving on a test site:

warning: XMLReader::read() [xmlreader.read]: /tmp/wordpress.2010-06-08_5.xml:163: namespace error : Namespace prefix itunes on summary is not defined in /home/agape3d1/public_html/sites/all/modules/wordpress_import/wordpress_import.module on line 1424.
warning: XMLReader::read() [xmlreader.read]: Podcast for Lt. Colonel in /home/agape3d1/public_html/sites/all/modules/wordpress_import/wordpress_import.module on line 1424.
warning: XMLReader::read() [xmlreader.read]: ^ in /home/agape3d1/public_html/sites/all/modules/wordpress_import/wordpress_import.module on line 1424.
warning: XMLReader::read() [xmlreader.read]: An Error Occured while reading in /home/agape3d1/public_html/sites/all/modules/wordpress_import/wordpress_import.module on line 1424.
This file does not appear to be a valid WXR file. The file is either corrupted or invalid XML. In some versions of WordPress, the export function can produce malformed XML. Please see README.txt (included in the module archive) for further guidance.

According to the first line of the error message, there seems to be an itunes-related module interfering with the export. Try disabling third-party Wordpress plugins before creating an WXR export file.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.