I can't create a Nivo Slider view, I keep getting this problem when I select Row style: Views Nivo Slider. Not exactly sure what's happening. By the way, thanks for making this module, this is a great solution compared to other slider modules! Just wish I could get it working.

An error occured at
/admin/build/views/ajax/preview/featured

Error Description:
Fatal error: Call to undefined method stdClass::theme() in /home/*/public_html/sites/all/modules/views_nivo_slider/views_nivo_slider.module on line 77

Title: None
Style: Views Nivo Slider
Row style: Views Nivo Slider
Use AJAX: No
Use pager: No
Items to display: 10
More link: No
Distinct: No
Access: Unrestricted
Caching: None
Exposed form in block: No
Header: None
Footer: None
Empty text: None
CSS class: None
Theme: Information

Relationships: None defined

Arguments: None defined

Fields
Content: Image frontpage_preview image

Sort criteria: None defined

Filters
Node: Type = Featured

Comments

Issue fixed. You have to fill in all fields for Nivo Slider in order to not get that error. Thought you could only do images for the view. Great module. Thanks!

Status:Active» Fixed

Assigned:Unassigned» pedrofaria
Status:Fixed» Closed (fixed)

You're right...

It's a bug... probably you didn't select one or two fields at Row Style Settings...

i am fixing it now and in a few minutes version 6.x-1.1 will be released!

Thanks

Status:Closed (fixed)» Fixed

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.

Hello, do you have a Views "Import" Paste code to make it work on the fly.

(Edit: for some reason, this didn’t appear in my Browser on refresh, so I reposted with more info as Post #8 below.)

Version:6.x-1.0» 7.x-3.x-dev
Priority:Minor» Major
Status:Closed (fixed)» Active

I’m having what appears to be the same issue, but in 7.x-3.x-dev, and the line number is 128, not 77 (“Call to undefined method stdClass::theme() in …/sites/all/modules/views_nivo_slider/views_nivo_slider.module on line 128”).

The thing is, it first happens for me as soon as I select “Views Nivo Slider” as my Row Style and click “Apply (this display)” and before the Settings dialog for the Views Nivo Slider Row Style even pops up to give me a chance to select any Fields for Image, Title, or Link.

It keeps on popping up every time I try to do anything thereafter with that Views Display, even after adding and setting up the necessary Fields and setting the proper Fields for Image, Title, and Link in the Views Nivo Slider Row Style Settings pop-up. Every time I change a Field setting, etc. And the Preview refuses to work.

This is a showstopper. We cannot proceed at all.