Hi there,

are there any plans to port this module to drupal 7?

Thanks,

Culfin

Files: 
CommentFileSizeAuthor
#20 node_comment_links.patch1.65 KBAlyx Vance

Comments

Of course — feel free to start with the work.

Title:Port to Drupal 7?Forum Access for D7 — ALPHA1
Version:6.x-1.3» 7.x-1.0-alpha1
Assigned:Unassigned» salvis
Category:feature» task
Priority:Normal» Major

We have ALPHA1 of Forum Access.

It has all the features of the D6 version plus extensive tests. It's only an alpha version because there's no support for unpublished nodes and comments yet — see #964698: How to handle unpublished nodes and comments in D7? for this discussion.

Forum Access requires the core patch in #553944-154: Define hook_menu_get_item_alter() as a reliable hook that runs before the page is doomed for complete functionality. If you are interested in having Forum Access for Drupal 7, please add your support for that patch over there.
Update: The patch was committed to core after Drupal 7 BETA3 — and I found a way for Forum Access to get by even without the new hook. Thus you can try the -dev version of FA with any version of D7.

Please test this version and provide feedback, both good and bad:

IF it works for you, let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!
Do NOT add bug reports to this issue here.

Category:task» bug
Priority:Major» Normal

I've never reported a bug before, so please let me what else you need.

After adding a comment to a forum entry, I receive this error:

Fatal error: Call to undefined function dpm() in F:\xampp\htdocs\navatribe\sites\all\modules\forum_access\forum_access.node.inc on line 147

This error recurs whenever that forum topic is accessed.

Running Drupal 7 RC1
on PHP 5.3.1
Using Forum Access version 7.x-1.0-alpha1

Title:Forum Access for D7 — ALPHA2Forum Access for D7 — ALPHA1
Category:task» bug
Priority:Major» Normal

NO, NOT HERE, PLEASE!!!

Please open your very own brand new issue for your very own bug!

EDIT: #3 has been fixed in ALPHA2, but please don't pollute this thread with random bug reports. Each bug needs its own issue so it can be managed and eventually closed.

Category:bug» task
Priority:Normal» Major

Title:Forum Access for D7 — ALPHA1Forum Access for D7 — ALPHA2

We have ALPHA2 of Forum Access.

This fixes a number of bugs and it now uses the new Chain Menu Access API module that provides safe and simple chaining of menu access callback functions.

If you update from ALPHA1, then be sure to install and enable Chain Menu Access API before updating to ALPHA2!

Please test this version and provide feedback, both good and bad:

IF it works for you, let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!
Do NOT add bug reports to this issue here.

Title:Forum Access for D7 — ALPHA1Forum Access for D7 — ALPHA2
Category:bug» task
Priority:Normal» Major

ALPHA2 is working for me so far, I shall give it more testing. =)

Thank you for a good module.

Best regards,
Ao

I tested forum access with Drupal 7rc2 with the following error/ warning message:

Warning: Call-time pass-by-reference has been deprecated in /PATH/drupal-7.0-rc2/sites/all/modules/forum_access/forum_access.module on line 383 Warning: Call-time pass-by-reference has been deprecated in /PATH/drupal-7.0-rc2/sites/all/modules/forum_access/forum_access.module on line 469

I also can't rebuild permissions with forum access installed...

Version:7.x-1.0-alpha1» 7.x-1.0-alpha2

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!
Do NOT add bug reports to this issue here.

Title:Forum Access for D7 — ALPHA2Forum Access for D7 — ALPHA3
Version:7.x-1.0-alpha2» 7.x-1.0-alpha3

We have ALPHA3 of Forum Access.

ALPHA3 provides a (yet untested!) upgrade path from D6. It has significant bug fixes and adjustments for recent changes in Drupal's Form API, and it's the first version that passes all its 10312 tests.

Be sure to update ACL to the new 7.x-1.0-beta2 version before installing ALPHA3.

Please test this version and provide feedback, both good and bad:

IF it works for you, let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!
Do NOT add bug reports to this issue here.

Working for me. :-)

Best regards,
Ao

Title:Forum Access for D7 — ALPHA3Forum Access for D7 — ALPHA4
Version:7.x-1.0-alpha3» 7.x-1.0-alpha4

We have ALPHA4 of Forum Access.

ALPHA4 has more major bug fixes and adjustments for recent changes in Drupal's Form API as well as clean-ups of the porting work in progress. It passes all its 10679 tests. The D6 upgrade path that I mentioned in #10 is still untested. I guess it's waiting for you to test it...

Be sure to have ACL 7.x-1.0-beta2 or later installed before installing ALPHA4.

Please test this version and provide feedback, both good and bad:

IF it works for you, let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!
Do NOT add bug reports to this issue here.

So far, so good. ALPHA4 is Working for me.

Thank you. :-)

Best regards,
Ao

I posted this over here too http://drupal.org/node/995214#comment-3986234 to because I'm not sure where I should be posting this.

* Warning: array_splice() expects parameter 3 to be long, string given in _chain_menu_access_callback() (line 59 of /var/www/drupal/sites/all/modules/chain_menu_access/chain_menu_access.module).

I'm running ACL 7.x-1.0-beta2
and Forum Access 7.x-1.0-alpha4

Is it possible to integrate this module with Organic Groups for D7?

I mean the scenario in which particular parts of Forum are designed exclusively to the corresponding groups, and can be seen only by the members of these groups.

#16: New thread, please.

Title:Forum Access for D7 — ALPHA4Forum Access for D7 — BETA1
Version:7.x-1.0-alpha4» 7.x-1.0-beta1

We have BETA1 of Forum Access.

BETA1 has a number of significant bug fixes as well as template support and handling of unpublished nodes. The latter is tentative — we haven't completely figured out yet how this is supposed to work. Also, the D6 upgrade path that I mentioned in #10 is still untested. I guess it's waiting for you to test it...

 

Please test this version and provide feedback, both good and bad:

IF this module works for you, please let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!

PLEASE do NOT add bug reports / questions to this issue here.

Forum Access BETA1 has been working for me. Thank you. :-)

Best regards,
Ao

StatusFileSize
new1.65 KB

wave
the modules works fine at the time
but i missing the links for
eg.: "login or register to leave a comment"
i have made a patch for this
can you check it out?

Thank you, but please open a separate issue for this and put your patch there. This issue here will be "fixed" when 1.0 is released, and I cannot handle specific feature requests or bug reports here (see #18, I'll add "feature requests" to the list next time). Your issue deserves its own Status indicator.

sorry
okya i do

Title:Forum Access for D7 — BETA1Forum Access for D7 — BETA2
Version:7.x-1.0-beta1» 7.x-1.0-beta2

We have BETA2 of Forum Access. Unfortunately, we're making very little progress here. Except for Ao (thank you!), no one seems to care to test and provide feedback that something is actually working, even though we have 1500 known sites using BETA1.

BETA2 wraps up a number of bug fixes. We're still desperately waiting for feedback on the D6 upgrade path as well as the handling of unpublished nodes...

 

Please test this version and provide feedback, both good and bad:

IF this module works for you, please let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!

PLEASE do NOT add bug reports / questions / feature requests to this issue here.

BETA 1 is working for me without problems (at least, I did not found any)

Testing is just fine. I've been customizing the builds to allow for posting of comments but not the posting of new forum posts, and it works very well.

There's not much to say except for that it works really well. Only requested feature I have is on another bug (allow posting of comments, but not new forum posts).

Using BETA1. Works as advertised (for my very limited needs). No bugs noticed to date.

Thank you for your work on this. I will be testing this module over the next couple of weeks. My project requires all forums to be private (members only). I hope this module works out. I will post back on my experience.

I am using this module with Advanced Forum module and it seems to work OK. Thanks :) !!!

Title:Forum Access for D7 — BETA2Forum Access for D7 — RC1
Version:7.x-1.0-beta2» 7.x-1.0-rc1

Thanks to those who provided feedback!

We have RC1 of Forum Access. Now is the time to update, do a last round of checking, and hopefully give the green light here.

There seems to be no interest in #964698: How to handle unpublished nodes and comments in D7? — this will remain open for 1.0.

 

Please test this version and provide feedback, both good and bad:

IF this module works for you, please let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!

PLEASE do NOT add bug reports / questions / feature requests to this issue here.

Title:Forum Access for D7 — RC1Forum Access for D7 — RC2
Version:7.x-1.0-rc1» 7.x-1.0-rc2

We have RC2 of Forum Access. This became necessary because of #1321864: Moderator does not see fields added to content type.. The fix may cause your moderators to see more fields on their node add/edit form than they saw before. Please verify that this is working as expected!

So, again, now is the time to update, do a last round of checking, and hopefully give the green light here.

There seems to be no interest in #964698: How to handle unpublished nodes and comments in D7? — this will remain open for 1.0.

 

Please test this version and provide feedback, both good and bad:

IF this module works for you, please let us know by adding a note to THIS issue here.

IF YOU FIND A BUG, please check the issues queue, and if it hasn't been reported yet, then OPEN A NEW ISSUE!

PLEASE do NOT add bug reports / questions / feature requests to this issue here.

Hello!

Thank you for your continued work on this module. I can safely say that RC2 is currently working on my system. :-)

Best regards,
Ao

Title:Forum Access for D7 — RC2Forum Access for D7
Version:7.x-1.0-rc2» 7.x-1.0
Assigned:salvis» Unassigned
Status:Active» Fixed

We have 1.0!

Thanks to everyone who cared to provide feedback!

Version:7.x-1.0» 7.x-1.0-rc2
Status:Fixed» Active

:)

Hooray!

Version 1.0 is installed and functional.

Status:Active» Fixed

Oops, did not mean to change the status.

Thanks Ao! :-)

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.