I don't really know if it's an issue or a misunderstanding on how it sohuld work.

I have this page http://www.filosofia.unipd.it/biblioteca/avvisi-novita, the taxonomy term is the first one 'biblioteca', because I have 4 section and every section has a 'news' section.

So I have 4 view '[term]/avvisi-novita' pages wich lists the filtered news.

Then, clicking on a news link, you are redirected to '[term]/avvisi-novita/title-of-news' (which is created with autopath). The problem, as you can see, is the the trail is not kept and the menù disappear and the breadcrumb is wrong.

What am I missing?

Thank you.

Comments

  1. Taxonomy Menu Trails doesn't handle breadcrumb, so use other modules. For example, Custom Breadcrumbs.
  2. Each news node in list on the page '[term]/avvisi-novita' has [term] attached, isn't it?
  3. Please, check Taxonomy Menu Trails module's settings page. Did you enable module for correct node type and vocabulary? Which term selection method do you use?

Thank you Dmitriy,

1. Yes sorry, I was pointing out also the breadcrumb issue just in case the two things were in some way related (and maybe they are, because if I try to use the taxonomy breadcrumb, it prints out the wrong path);

2. I'm not sure if I get it right. Do you mean if I have a field with term in the view or if I have set the view path as '%/avvisi-novita' ?

3. Yes it's enabled and the the selection is "First term"

Status:Active» Postponed (maintainer needs more info)

First of all, sorry for late answer. Do you still have a problem? Your site is working as expected now, as I can see.

Status:Postponed (maintainer needs more info)» Fixed

Closed due to inactivity. Feel free to reopen if module still doesn't work as expected.

Status:Fixed» Closed (fixed)

Automatically closed -- issue fixed for 2 weeks with no activity.