I installed Drupal on a GoDaddy subdirectory as a test site, got it working, and then created a new hosting account under a new domain to deploy the main site. I'm confused now, though, because I never had any problems with installing Drupal on GoDaddy until now. I didn't really have a clean install - I got some permissions errors after the main configure setup, and nothing seems to be going well. I'm getting permissions issues on everything... what am I doing wrong? I can create nodes, but I can't add modules, themes, or run cron without getting red text each time. I followed the instructions in the installer guide to the letter.

Warning: opendir(/tmp/update-cache) [function.opendir]: failed to open dir: Permission denied in DrupalLocalStreamWrapper->dir_opendir() (line 700 of /home/content/20/7361820/html/includes/stream_wrappers.inc).
Warning: opendir(temporary://update-cache) [function.opendir]: failed to open dir: "DrupalTemporaryStreamWrapper::dir_opendir" call failed in file_scan_directory() (line 1975 of /home/content/20/7361820/html/includes/file.inc).
Warning: opendir(/tmp/update-extraction) [function.opendir]: failed to open dir: Permission denied in DrupalLocalStreamWrapper->dir_opendir() (line 700 of /home/content/20/7361820/html/includes/stream_wrappers.inc).
Warning: opendir(temporary://update-extraction) [function.opendir]: failed to open dir: "DrupalTemporaryStreamWrapper::dir_opendir" call failed in file_scan_directory() (line 1975 of /home/content/20/7361820/html/includes/file.inc).

Cron run successfully.

=================

Is this anything I should be concerned about? If so, how do I rectify? Thanks so much!

Comments

momchenr’s picture

It's also not letting me install modules:

===============
The specified file temporary://fileq4VUL3 could not be copied, because the destination directory is not properly configured. This may be caused by a problem with file or directory permissions. More information is available in the system log.
http://ftp.drupal.org/files/projects/cck-7.x-2.x-dev.zip could not be saved to temporary://update-cache/cck-7.x-2.x-dev.zip.
Unable to retrieve Drupal project from http://ftp.drupal.org/files/projects/cck-7.x-2.x-dev.zip.
===============

Ne0nx3r0’s picture

I'm also getting a cron error on a fresh install downloaded and setup just moments ago using GoDaddy:

Warning: opendir(/tmp/update-extraction) [function.opendir]: failed to open dir: Permission denied in DrupalLocalStreamWrapper->dir_opendir() (line 700 of /path/to/root_and_drupal/includes/stream_wrappers.inc).
Warning: opendir(temporary://update-extraction) [function.opendir]: failed to open dir: "DrupalTemporaryStreamWrapper::dir_opendir" call failed in file_scan_directory() (line 1975 of /path/to/root_and_drupal/includes/file.inc).
momchenr’s picture

Try it again but this time make sure that you're following the Quick FTP directions exactly. I got it to work by setting only the sites/default directory to 777 in filezilla, and NOT letting those permissions downward-inherit. It seems like we have the same problems, so try it again, but don't be tempted to change everything to 777 - Drupal seems picky about its file permissions, so do it exactly as it says.

Create a temporary directory. I did this and it got rid of temp-dir warnings and errors. Create some temp folder somewhere, like \tmp, then go into your configuration manager page and specify that location as its temporary directory.

christopher james francis rodgers’s picture

DO NOT Use "~". Do NOT use "/....."

All you really need to do if you are having problems is to remove the forward-slash ("/") from "/tmp"
and specify 

tmp 

only at --> [Your-D7-root-home] » Administration » Configuration » Media: File system » Temporary directory.

See http://drupal.org/node/1106492#comment-4562780 for more details if you want them.


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

christopher james francis rodgers’s picture

The solution for me was simply..
.
Go to 'Configuration' > 'Media' > 'File System'
[*root*]/admin/config/media/file-system
and change the 'Temporary directory' from
/tmp to ~/tmp
.
=========
.
This problem was a new one to me today
using BlueHost.com although I had done nothing differently
than I had any other time over the last several months.
.
See http://drupal.org/node/1091580#comment-4231440
if you are interested in more of my sordid details
.
.
.
-cjfr


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

e-ng’s picture

/tmp to ~/tmp works on GoDaddy.

christopher james francis rodgers’s picture

DO NOT Use "~". Do NOT use "/....."

All you really need to do if you are having problems is to remove the forward-slash ("/") from "/tmp"
and specify 

tmp 

only at --> [Your-D7-root-home] » Administration » Configuration » Media: File system » Temporary directory.

See http://drupal.org/node/1106492#comment-4562780 for more details if you want them.


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

nateb’s picture

Not here. Which GoDaddy hosting tier are you on?

christopher james francis rodgers’s picture

DO NOT Use "~". Do NOT use "/....."

All you really need to do if you are having problems is to remove the forward-slash ("/") from "/tmp"
and specify 

tmp 

only at --> [Your-D7-root-home] » Administration » Configuration » Media: File system » Temporary directory.

See http://drupal.org/node/1106492#comment-4562780 for more details if you want them.


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

christopher james francis rodgers’s picture

I was wrong to recommend that above; and I can not change that post now.

All you really need to do if you are having problems is to remove the forward-slash ("/") from "/tmp"
and specify 

tmp 

only at --> [Your-D7-root-home] » Administration » Configuration » Media: File system » Temporary directory.

2011.06.06 See http://drupal.org/node/1106492#comment-4562780

Do not use "~" as "Temporary Directory" location:

My original recommendation of simply adding
a "~" character in front of D7's default of "/tmp"
in the field-box "Temporary directory"
at "Configuration" > "Media: File system"
causes D7 to create your temporary D7 folder
in your site's folders
at [d7-root]/~/
.

Additionally, and more importantly,
if you try to delete those unwanted files
using an FTP program,
you may, like me, find that trying
to navigate into ANY folder named "~"
on your wbhost site using FTP,
causes you to be immediately taken
to your website's root folder—
which is to say that you can not access those
temporary files using FTP to delete them.
and you will have to delete the temporary files
via your webhost's Control Panel (CPanel).


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

christopher james francis rodgers’s picture

I cannot edit my Comment above because it has been replied to...

do Not use "~" because it can cause problems.

For the total solution See http://drupal.org/node/1106492 for all the details.

All you really need to do if you are having problems is to remove the forward-slash ("/") from "/tmp"
and specify

tmp

only at --> [Your-D7-root-home] » Administration » Configuration » Media: File system » Temporary directory.


All the best; intended.
-Chris (great-grandpa.com)
___
"The number one stated objective for Drupal is improving usability." ~Dries Buytaert *

atpresources’s picture

worked for me

change:
/tmp to ~/tmp