• Advisory ID: DRUPAL-SA-CONTRIB-2012-050
  • Project: CDN2 Video (third-party module)
  • Version: 6.x
  • Date: 2012-March-28
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Multiple vulnerabilities

Description

CDN2 is a plug and play module and video management service for Drupal.
The module does not sanitize output correctly, allowing for a cross-site scripting (XSS) vulnerability. Additionally, the Form API is not correctly utilized allowing for cross-site request forgery (CSRF) attempts.

This module relies on a backend service that is no longer active therefore the project is unsupported.

For the XSS issue -
CVE: CVE-2012-2154
For the CSRF issue -
CVE: CVE-2012-2155

Versions affected

All versions are affected.

Drupal core is not affected. If you do not use the contributed CDN2 Video module, there is nothing you need to do.

Solution

Uninstall the module. This module is no longer supported.

Also see the CDN2 Video project page.

Reported by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.