Description

CVE: CVE-2012-2084

This module provides printer-friendly versions of content, including send by e-mail and PDF versions.
The module doesn't sufficiently escape URL elements which are printed back to the user.

Versions affected

  • Printer, email and PDF versions 6.x-1.x versions prior to 6.x-1.15.
  • Printer, email and PDF versions 7.x-1.x versions prior to 7.x-1.0.

Drupal core is not affected. If you do not use the contributed Printer, email and PDF versions module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Printer, email and PDF versions project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.