• Advisory ID: DRUPAL-SA-CONTRIB-2013-048
  • Project: Edit Limit (third-party module)
  • Version: 7.x
  • Date: 2013-May-29
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass

Description

Edit Limit enables you to set time and count-based limits on how and when a user can edit nodes or comments.

The module doesn't sufficiently check user access when editing comments to see if the user has the necessary permissions to edit a comment outside of the limits applied by this module. This makes it possible for a user who can edit their own comments to edit the comments of any other user.

This vulnerability is mitigated by the fact that an attacker must have a role with the permission "edit comments".

CVE identifier(s) issued

  • CVE-2013-2122

Versions affected

  • Edit Limit 7.x-1.x versions prior to 7.x-1.3.

Drupal core is not affected. If you do not use the contributed Edit Limit module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Edit Limit project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.