• Advisory ID: DRUPAL-SA-CONTRIB-2013-059
  • Project: Hostmaster (Aegir) (third-party module)
  • Version: 6.x
  • Date: 2013-July-17
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Access bypass

Description

This install profile and accompanying suite of modules enables you to install, upgrade, deploy, and backup Drupal sites (among other things.)
The module doesn't sufficiently control access to running tasks on sites, under the scenario where a user successfully guesses a sites' path in the Aegir front-end.
This vulnerability is mitigated by the fact that an attacker must be authenticated and have a role with one or more permissions that allow the creation of tasks.

CVE identifier(s) issued

  • A CVE identifier will be requested, and added upon issuance, in accordance with Drupal Security Team processes.

Versions affected

  • Hostmaster 6.x-1.x versions prior to 6.x-1.10.

Drupal core is not affected. If you do not use the contributed Hostmaster (Aegir) module, there is nothing you need to do.

Solution

Install the latest version:

Also see the Hostmaster (Aegir) project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.