Change record status: 
Project: 
Introduced in branch: 
8.x
Introduced in version: 
8.0
Description: 

drupal_parse_dependency() has been moved into the \Drupal\Core\Extension\ModuleHandler::parseDependency() class. The functionality is the same as in Drupal 7.

<?php
// Drupal 7
$dependency_info = drupal_parse_dependency('example (>=7.x-2.1)');
// Drupal 8
// This line, like all 'use' statements, belongs at the top of the respective file.
use Drupal\Core\Extension\ModuleHandler;
$dependency_info = ModuleHandler::parseDependency('example (>=8.x-1.3)');
?>
Impacts: 
Module developers
Updates Done (doc team, etc.)
Online documentation: 
Not done
Theming guide: 
Not done
Module developer documentation: 
Not done
Examples project: 
Not done
Coder Review: 
Not done
Coder Upgrade: 
Not done
Other: 
Other updates done