Closed (fixed)
Project:
Privatemsg
Component:
Code
Priority:
Major
Category:
Bug report
Assigned:
Reporter:
Created:
25 Sep 2010 at 06:30 UTC
Updated:
3 Nov 2010 at 12:50 UTC
Jump to comment: Most recent file
hi
i am using Privatemsg 6.x-2.x-dev latest version.
& i got this error
user warning: Table 'vividbase.pm_disable' doesn't exist query: privatemsg_is_disabled /* dhaval : privatemsg_is_disabled */ SELECT 1 FROM pm_disable WHERE uid = 1 in C:\xampp\htdocs\vivid\sites\all\modules\privatemsg\privatemsg.module on line 308.
plz help me..
| Comment | File | Size | Author |
|---|---|---|---|
| #6 | privatemsg_fix_update_functions.patch | 3.68 KB | berdir |
| #4 | Quieries.png | 16.28 KB | imDhaval |
| #4 | errors.png | 43.33 KB | imDhaval |
Comments
Comment #1
berdirDid you run update.php?
Comment #2
imDhaval commentedthnx for ans. me
yes Berdir i did run update.php
but problem still occurs
need help......
Comment #3
berdirOh crap, I see the problem :)
Try re-running the 6007 update function.
We have an overlap there...
Comment #4
imDhaval commentedok!! i re-run the 6007 update function of Privatemsg module
& it works ..
wow...
user warning: Table 'vividbase.pm_disable' doesn't exist query: privatemsg_is_disabled /* dhaval : privatemsg_is_disabled */ SELECT 1 FROM pm_disable WHERE uid = 1 in C:\xampp\htdocs\vivid\sites\all\modules\privatemsg\privatemsg.module on line 308.error solved.
but i got few new things & i attach them below, just look at them & tell me about them
thnx
Comment #5
berdirThats ok. These errors happened because the function 6008-6010 were run a second time.
Comment #6
berdirOk, here is a try at fixing this mess :)
Basically, all update functions that were added in 6.x-2.x are renamed to 620X and a a check is added for most of them so that they are not run twice for those that are already using 6.x-2.x.
I need some confirmation that this works correctly, bot upgrading for 6.x-1.x and 6.x-2.x. For 6.x-2.x, there shouldn't be any errors/messages at all and for 6.x-1.x it should run all update functions without errors and everything should work correctly on the site after that.
Comment #7
berdirCommited.