nice_menus.png

Nice Menus enables drop-down/right/left expandable menus. It uses only CSS for most browsers, with minimal Javascript for IE6. (Version 2 uses the Superfish jQuery plugin for all browsers, with an option to disable JS, and falls back to CSS-only for browsers that can handle it.)

Three styles/types of menus are currently possible: horizontal, menus drop down; vertical, menus fly to the left; vertical, menus fly to the right. There is a handbook page that provides a list of sites that use Nice menus.

Nice Menus creates blocks that may be associated with any existing site menu which can be placed wherever normal blocks can be placed in a theme. For themers, it is also possible to theme a menu as a Nice Menu directly by using the provided theme functions so a block is not necessary. A specific theme function for the Primary Links menu is available. The theme functions also allow a developer to pass in a custom menu tree of their making (i.e. not using a Drupal menu.) There is more information on how to use theme functions in the documentation.

The module comes with a simple, generic color scheme which can be fully overridden either by adding the override CSS to the theme's normal stylesheet or by creating a Nice Menus CSS file and telling Nice Menus to use that rather than its own default one through the global theme configuration. Several CSS override examples are provided in the included README.txt file and in the handbook.

If you are having problems with Nice Menus, make sure you read the FAQ and search the issue queue to see if others have already addressed them.

CSS Problems: Nice menus will give you easy to use, plug and play blocks with flyout menus but does require CSS work to get customized styling. CSS support issues are not supported in this issue queue and will be closed. If you have CSS styling questions, you can try asking on the forums, #drupal-themes IRC or the Themes mailing list.

Version 2

The 6.x-2.x version has many new features and some rewriting. This is what the Drupal 7 upgrade will be written from. The 1.x version of Nice Menus will not be supported once Drupal 7 is released.

********************************************************
UPGRADE NOTE: You MUST read the UPGRADE.txt if upgrading from 6.x-1.x. You should run upgrade.php to make sure all updates happen AND the cache gets cleared. Notable changes include: the theme function names have changed so if you are using them in your theme templates you will need to update the function name when you upgrade, and there are also several important CSS changes as well which could effect your custom CSS.

Major new features in 6.x-2.x:
#135771: Choose starting and ending menu depth
#219804: Set active menu trail CSS selectors
#322962: Add configurable JS with Superfish
#300628: Support menu translation (i18n)
#301247: add classes 'first', 'last', 'even', 'odd'

nice_menus-7.x-2.4 support Upgrade included hoverIntent, jquery.bgiframe and
superfish plugin, requirement for jQuery 1.7+ #2001616: Upgrade included Superfish library to the latest version 1.7.4 (currently shipping 1.4.8). download plugins to:
site/all/libraries/jquery.hoverIntent/jquery.hoverIntent.js
site/all/libraries/jquery.bgiframe/jquery.bgiframe.js
site/all/libraries/superfish/superfish.js

Nice Menus 7.x-3.x require jQuery >= v1.7 #2036601: Create a 7.x-3.x branch to support the latest versions of required js libraries - Keep 7.x-2.x compatible with default Drupal.

Project Information

Downloads