Project: 
Project machine name: 
scheduler
Date: 
2026-November-04
Vulnerability: 
Access bypass
Affected versions: 
<1.7.0 || >=2.2.0 <2.2.3 || 2.0.* || 2.1.* || >= 2.3.0 <2.3.1
CVE IDs: 
CVE-2026-122075
Description: 

This module enables you to schedule content to be published or unpublished at a certain time in the future.

The module doesn't sufficiently check if a user has permission to change publication or unpublication dates. This might cause certain information to be publicly disclosed ahead of the scheduled time, or content to become inaccessible earlier or later than planned.

This vulnerability is mitigated by the fact that an attacker must already have permission to edit the affected content, and the content must be editable through a web services API like JSON:API or REST.

Solution: 

Install the latest version:

  • If you use version 8.x-1.x, upgrade to Scheduler 8.x-1.7.
  • If you use version 2.2.x, upgrade to Scheduler 2.2.3.
  • If you use version 2.3.x, upgrade to Scheduler 2.3.1.
  • Version 2.1.x branch is no longer supported. Sites on this version should update to 2.2.3 or 2.3.1.
Coordinated By: