• Advisory ID: DRUPAL-SA-CONTRIB-2012-058
  • Project: Fivestar (third-party module)
  • Version: 6.x
  • Date: 2012-April-11
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Input Validation

Description

CVE: CVE-2012-2096

The Fivestar module enables you to add a voting widget to nodes and comments.

The module does not sufficiently validate all votes passed by the asynchronous voting widget allowing a malicious user to improperly modify voting averages.

Versions affected

  • Fivestar 6.x-1.x versions prior to 6.x-1.20

Drupal core is not affected. If you do not use the contributed Fivestar module, there is nothing you need to do.

Solution

Install the latest version:

  • If you use the Fivestar module for Drupal 6.x, upgrade to Fivestar 6.x-1.20

Also see the Fivestar project page.

Reported by

Fixed by

Coordinated by

Contact and More Information

The Drupal security team can be reached at security at drupal.org or via the contact form at http://drupal.org/contact.

Learn more about the Drupal Security team and their policies, writing secure code for Drupal, and securing your site.