• Advisory ID: DRUPAL-SA-CONTRIB-2009-057
  • Project: Date (third-party module)
  • Version: 5.x, 6.x
  • Date: 2009-September-16
  • Security risk: Moderately critical
  • Exploitable from: Remote
  • Vulnerability: Cross Site Scripting

Description

The Date module provides a date CCK field that can be added to any content type. The Date module does not properly escape user data correctly in some cases when setting the page title. A malicious user with permission to post date content could attempt a cross site scripting (XSS) attack when creating or editing content, leading to the user gaining full administrative access.

Versions affected

  • Date for Drupal 6.x prior to 6.x-2.4
  • Date for Drupal 6.x prior to 5.x-2.8

Drupal core is not affected. If you do not use the contributed Date module, there is nothing you need to do.

Solution

Upgrade to the latest version:

See also the Date project page.

Reported by

The Acquia, Inc. support team

Fixed by

Karen Stevenson, the project maintainer.

Contact

The security contact for Drupal can be reached at security at drupal.org or via the form at http://drupal.org/contact.