PLEASE READ #1882650: Source DB tables get dropped if db-url not set BEFORE UPGRADING. Your target site alias must be set up correctly before you begin.

The new home for site-upgrade drush command, which streamlines the major version upgrade process for Drupal. Currently, only upgrades from Drupal 6 to Drupal 7 are supported. See https://www.acquia.com/blog/use-drush-upgrade-drupal-6-drupal-7.

The Drush site upgrade command will walk you through the major upgrade process, help you select new projects where necessary, and run content migrate to update your cck fields. Please be sure to read the documentation and take note of any special conditions you may encounter. See the README.txt file for more information.

INSTALLATION:

cd ~
drush dl drush_sup

OTHER NOTES:

If your site uses Features, see #1014522: Upgrade existing features to D7.

If your site has shared database tables, see #1602996: Drush site upgrade doesn't support shared database tables (db_prefix w/ array values).

IMPORTANT: Drush Sup 7.x-2.x requires Drush 5.4 or later, AND IS BROKEN UNDER DRUSH 6. See #2129085: Module release availability fails to fetch on Drush 6

The 7.x-1.x branch is no longer recommended or supported; it contains only bug fixes for the original implementation of the drush site-upgrade command from drush core. It only works well enough to successfully upgrade very simple sites with just a few contrib modules. The 7.x-2.x branch should be used instead.

Project Information

Downloads