This module provides a field for geospatial data that can be added to entities. To the end user this module is similar to the Geofield module, but spatial operations and data storage rely on PostGIS. The module is developed as part of the Cartaro distribution but can be used on its own, too.

Using the OpenLayers Editor module to edit geospatial data stored in a PostGIS database:

Editing using Drupal PostGIS module and OpenLayers Editor

Requirements

  • PostGIS 1.5 or later. Some features might work with older versions.
  • OpenLayers module if you want to display geospatial data on maps.

Related Projects

Documentation

Project Information

Downloads